11-10-2013, 06:52 PM
I think I'm getting to the point where I can start being productive proper, again.
Sorry to come to you lot so soon but it's not really asking for a solution, it's just asking for a name. In Mask, I've been thinking about how I have like 2-3 separate variables for specific numerical values so I was considering creating a Class similar in concept to a Fraction that would store the current value, the maximum value and perhaps the initial value when the object was constructed. I could also implement checks to prevent exceeding the max and all that jazz too from one implementation.
Thing is... I don't know what to call it. I would use "Fraction" but that doesn't feel correct, it implies a strictly mathematical context. I would use something like "Stat" or "Status" but I'm using the former as enums to refer to those specific stats (HP, FP, BP, POW, DEF, etc.) and the latter as an enum to refer to specific statuses like Dodgy or Hurt.
Sorry to come to you lot so soon but it's not really asking for a solution, it's just asking for a name. In Mask, I've been thinking about how I have like 2-3 separate variables for specific numerical values so I was considering creating a Class similar in concept to a Fraction that would store the current value, the maximum value and perhaps the initial value when the object was constructed. I could also implement checks to prevent exceeding the max and all that jazz too from one implementation.
Thing is... I don't know what to call it. I would use "Fraction" but that doesn't feel correct, it implies a strictly mathematical context. I would use something like "Stat" or "Status" but I'm using the former as enums to refer to those specific stats (HP, FP, BP, POW, DEF, etc.) and the latter as an enum to refer to specific statuses like Dodgy or Hurt.